Splunk Search

Plot graph using timechart

hikari992
Explorer

Hi everyone, I'm quite new to splunk. I'm trying to plot a graph using timechart with starting time of the event and the ending time of the event.

This is my search query:


sourcetype="Traffic" | stats earliest(_time) as startOfEvent latest(_time) as endOfEvent range(_time) as duration by Message

This is the return result from the query:


Message | startOfEvent | endOfEvent| duration

msg1 | 1368457298 | 1368459923 | 2625

msg2 | 1368457298 | 1368457821 | 523


How can i turn this into a timechart?

Any help is appreciated.
Thanks!

0 Karma

alacercogitatus
SplunkTrust
SplunkTrust

If you could include some metrics you would like, it might be easier to show you specifics. But the general format is:

sourcetype="Traffic" | timechart count by Message span=5m

This will show the count by Message over time.

http://docs.splunk.com/Documentation/Splunk/5.0.2/SearchReference/Timechart

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...