Splunk Search

One MAC multiple IP's Table View

hartfoml
Motivator

I have a search like this

index="wireless" DHCP ACK | table _time src_mac src_ip

I would like to show a table of MAC and the assoseated IP's the MAC has used and when it recieved the IP

Like this:


fc:c7:34:de:58:56 1/1/2013 123.45.6.789

                           1/2/2013       123.45.6.978

fc:25:3f:a0:6d:bb 2/1/2013 123.45.6.912

                           2/3/1023       123.45.6.864

Tags (3)
0 Karma
1 Solution

Ayn
Legend

How about

index="wireless" DHCP ACK | stats list(_time) as time,list(src_ip) as src_ip by src_mac | convert ctime(time)

View solution in original post

0 Karma

Ayn
Legend

How about

index="wireless" DHCP ACK | stats list(_time) as time,list(src_ip) as src_ip by src_mac | convert ctime(time)
0 Karma

hartfoml
Motivator

If I could bother you for one more thing.

If I wanted to use the transaction commend but only find the src_mac that have more than one IP how could I do that?

0 Karma

hartfoml
Motivator

Wow this is great stuff. Thanks Ayn

0 Karma

Ayn
Legend

...or if you want to use transaction for some reason,

index="wireless" DHCP ACK | transaction src_mac | table src_mac _time src_ip
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Mile High Learning with Splunk University, Denver, Colorado

If Denver is known for its mile-high elevation, Splunk University is about to raise the bar on technical ...

IT Service Intelligence 5.0 Series: Your Guide to the June Launch

We are excited to announce the June release of Splunk IT Service Intelligence (ITSI) 5.0. This update ...

Agent Mode Engaged! Enchaining Agentic Operations with Splunk AI Assistant 2.0

    Are you ready to transform how your team handles complex data requests? We invite you to our upcoming ...