Splunk Search

Multisearch

HealyManTech
Explorer

Is there a way to have if you extract data from a search to have it fun in another search? Like putting the field value into another search without having to manually type or script it out?

Example:

index=wineventlogs action=delete
| rex field=_raw "GID : (?.*)"
| table _time, ID
| (NEW Search) "ID" (how would I get that to populate)

Would I have to do a multisearch??

Thanks for the help.

0 Karma

logloganathan
Motivator

Could you please try like this

index=wineventlogs action=delete
| rex field=_raw "GID : (?.*)"
| table _time, ID | join ID | [ Search "your query" | table ID, "any values you want" ] | table table _time, ID,"any values you want"

or

index=wineventlogs action=delete
| rex field=_raw "GID : (?.*)"
| table _time, ID | append | [ Search "your query" | table ID, "any values you want" ] | table table _time, ID,"any values you want"

Please refer the below document.it will help you
for append
http://docs.splunk.com/Documentation/Splunk/7.0.3/SearchReference/Append

0 Karma

HealyManTech
Explorer

I tried this but didn't work. I am trying to get the rex ID created field to be part of the new search but errors out.

0 Karma

logloganathan
Motivator

do you want regex expression? i have provided example which tells how to do multisearch

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Make Your Machine Data AI-Ready in Splunk

Every team is getting ready for AI agents.   Thursday, November 12, 2026  |  11AM  PST / 2PM EST   ...

Splunk Asynchronous Forwarding Explained

Splunk asynchronous forwarding is often misunderstood as simply setting autoLBVolume. That is not quite right. ...

How to Monitor AI Agents with Splunk Agent Observability

Let’s say I’m running a travel planning AI app in production. A user asks for three concise hotel options in ...