Splunk Search

Join with different fields names.

brodde
Engager

Hi,

I'm trying to port some SQL queries we wrote to Splunk but whereas with SQL I can specify which columns to join whatever their names are I couldn't replicate that in Splunk.

Here's an attempt using aliases (rename didnt work either) :

   sourcetype="call"
    | join type=left callerID as userId
       [search sourcetype="user"
       | fields userId]
    | table event_id callerID userId

Thanks !

Tags (1)

martin_mueller
SplunkTrust
SplunkTrust

Rename certainly works.

If you have two sources like this:

user, field1
foo, value2

and like this:

userId, field2
foo, value2

you can do a search like this:

sourcetype=st1 | rename user as userId | join userId [search sourcetype=st2]

to get this:

userId, field1, field2
foo, value1, value2
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...