Splunk Search

Identify duplicate values in a field

azulueta
New Member

Hi,

I am new to Splunk and am looking for a search that is able to identify duplicate field values. We have an issue in Tenable that assets have duplicate asset IDs. My initial search is:

index=tenable sourcetype=tenable:io:assets
| stats count by hostnames, agent_uuid

Lists hostnames with ther unique ID on a table. Need to just show hostnames with the same agent_uuid.

I don't know if I need to export this and put it on a lookup table and then compare the agent_uuid values from there and just show the duplicates but I was hoping for a more straight forward search to do this. 🙂

Thank you.

0 Karma

yeahnah
Motivator

Hi @azulueta 

Try the following query

index=tenable sourcetype=tenable:io:assets
| stats count values(hostnames) BY agent_uuid
| where count > 1

Hope that helps

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...