Splunk Search

How to write query to exclude the logs having src_ip starting with either 10 or 172?

biswa2112
Engager

I have this query in Splunk which gets me the src_ip  along with different fields  for the particular UserId. But i want to exclude the logs having src_ip starting with either 10 or 172 . Could someone please help  

 

index=wineventlog $UserId sourcetype="WinEvt:ADFS" EventCode=120* | rex "IpAddress\W(?<src_ip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})" | rex "Activity\sID\W(?<Activity_ID>\s.*)" | table src_ip, Activity_ID, _time, UserAgent | sort _time | reverse

Labels (3)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust
index=wineventlog $UserId sourcetype="WinEvt:ADFS" EventCode=120* 
| rex "IpAddress\W(?<src_ip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})" 
| regex src_ip!="^10\.|^172\."
| rex "Activity\sID\W(?<Activity_ID>\s.*)" 
| table src_ip, Activity_ID, _time, UserAgent 
| sort 0 - _time

View solution in original post

ITWhisperer
SplunkTrust
SplunkTrust
index=wineventlog $UserId sourcetype="WinEvt:ADFS" EventCode=120* 
| rex "IpAddress\W(?<src_ip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})" 
| regex src_ip!="^10\.|^172\."
| rex "Activity\sID\W(?<Activity_ID>\s.*)" 
| table src_ip, Activity_ID, _time, UserAgent 
| sort 0 - _time
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...