Splunk Search

How to separate the fields AppDomainName and ApplicationSource in timechart?

lsy9891
Engager

Hi
I have this query that counts the number of errors for two applications but I get the application names from different fields-one from appdomainname and one from application source. I want these two different applications to display as two different lines in my chart. I tried this but it only shows EcomSubscription as a bar chart?

earliest=-1d@d latest=@d host="NETAPPA*" sourcetype="WinEventLog:Application" AND (AppDomainName= EcomSubscription.* OR ApplicationSource="/order*") AND "ErrorGUID" | eval application =  AppDomainName.":".ApplicationSource | timechart span=1h count BY application
0 Karma

Sukisen1981
Champion

|eval application = if (isnotnull(AppDomainName),AppDomainName,ApplicationSource) |timechart <..rest of the stuff>

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk Enterprise Security: An Automated Phishing Response Workflow

Originally posted on Splunk.com.   Key takeaways  The volume of phishing emails can overwhelm even the most ...

Sharper ES Detections, Agentic AI Integrations, Smarter Workload Management, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

Data Outage Monitoring and Reporting

We’ve all been there, right? Living our best life, working on our Splunk environment, when out of nowhere a ...