Splunk Search

How to resolve high increase in forwarders reporting errors, including "Failed to checkpoint" for channel='security'?

jcleary47
Path Finder

We discovered that in early April, around the 7th, we had a HUGE increase in forwarders reporting this error:

ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\bin\splunk-winevtlog.exe"" splunk-winevtlog - WinEventLogChannel::init: Failed to checkpoint for channel='security'
  • It's showing up on Windows 7, Windows 10, Server 2012, Server 2016 machines
  • Most of our forwarders are 7.1.2 but we have a few older versions out there.
  • Most of the hosts I've found with this error are Windows 10
  • No consistency in terms of OS or Forwarder versions where this error is showing up

Also, come to find out, this appears to correlate with events being missed from the Windows Event Security Logs and not being forwarded properly.

The ONLY thing that happened around when this seemed to spread like wildfire was Windows patches were deployed in our environment.

Has anyone else seen this issue?

The search we run to identify them is this if anyone wants to take a look to see if they have the errors as well:

index=_internal sourcetype=splunkd AND ERROR AND Security AND "Failed to checkpoint" AND log_level=ERROR 
| stats count by host

We have a case open with Splunk, but the suggested fixes do not seem to be resolving the errors.

CarsonZa
Contributor

converting UF to use service account seems to have fixed it for me. So if that's not possible at least you know that its a permissions issue with localsystem.

0 Karma

vanvan
Path Finder

I am having the same issue repeatedly in our Win'16 environment. Anyone found the cure yet?

0 Karma

morethanyell
Builder

No update?

0 Karma

splunk68
Path Finder

Getting the same ERROR messages randomly on Windows 2016 servers with forwarders on 7.3.3.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Request for Professional Development: Attending .conf26

Winning Over the Boss: Your Pass to .conf26 conf26 is going to be here before you know it. If don't already ...