Splunk Search

How to resolve high increase in forwarders reporting errors, including "Failed to checkpoint" for channel='security'?

jcleary47
Path Finder

We discovered that in early April, around the 7th, we had a HUGE increase in forwarders reporting this error:

ERROR ExecProcessor - message from ""C:\Program Files\SplunkUniversalForwarder\bin\splunk-winevtlog.exe"" splunk-winevtlog - WinEventLogChannel::init: Failed to checkpoint for channel='security'
  • It's showing up on Windows 7, Windows 10, Server 2012, Server 2016 machines
  • Most of our forwarders are 7.1.2 but we have a few older versions out there.
  • Most of the hosts I've found with this error are Windows 10
  • No consistency in terms of OS or Forwarder versions where this error is showing up

Also, come to find out, this appears to correlate with events being missed from the Windows Event Security Logs and not being forwarded properly.

The ONLY thing that happened around when this seemed to spread like wildfire was Windows patches were deployed in our environment.

Has anyone else seen this issue?

The search we run to identify them is this if anyone wants to take a look to see if they have the errors as well:

index=_internal sourcetype=splunkd AND ERROR AND Security AND "Failed to checkpoint" AND log_level=ERROR 
| stats count by host

We have a case open with Splunk, but the suggested fixes do not seem to be resolving the errors.

CarsonZa
Contributor

converting UF to use service account seems to have fixed it for me. So if that's not possible at least you know that its a permissions issue with localsystem.

0 Karma

vanvan
Path Finder

I am having the same issue repeatedly in our Win'16 environment. Anyone found the cure yet?

0 Karma

morethanyell
Builder

No update?

0 Karma

splunk68
Path Finder

Getting the same ERROR messages randomly on Windows 2016 servers with forwarders on 7.3.3.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

How much can you really learn in 3 minutes?

Observability can certainly be hard to understand – there's a lot of jargon and buzzwords and it seems to ...

Event Series: The Agentic SOC: Trust Before Autonomy

AI is fundamentally changing security operations, but true progress requires more than just automation—it ...

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...