Splunk Search

How to remove "N/A" while the SingleValue query loads

harshal_chakran
Builder

Hi,

I have a Postprocess search command in a Dashboard , which wait for couple of seconds to display the output. I am using a "Single Value" to display the result. But while the data is processed, "N/A" is being showed up. I tried everything, but not able to remove it.

Is it possible to remove the "N/A" from UI. Or is there any other means by which we can show a single line result for our search command other than single value.

<module name="PostProcess" layoutPanel="panel_row1_col1">
<param name="search">eval title="Choose any single Value"|table title</param>
<module name="SingleValue"></module>
</module>

Please Help...!!!

0 Karma
1 Solution

somesoni2
Revered Legend

If you're using sideview utils, your can use combination of ResultValueSetter and HTML module to show your result.

<module name="PostProcess" layoutPanel="panel_row1_col1"> <param name="search">eval title="Choose any single Value"|table title</param> 
 <module name="ResultsValueSetter">
              <param name="fields">title </param>
              <module name="HTML" layoutPanel="panel_row2_col1">
                <param name="html">
                  <![CDATA[ <table cellpadding="4" cellspacing="0" style="width: 100%;">
                                          <tr>
                                              <th align="left">
                                                 $title$
                                              </th>
                                          </tr> 
                                   </table>  ]]>
                </param>
              </module>
          </module>

View solution in original post

somesoni2
Revered Legend

If you're using sideview utils, your can use combination of ResultValueSetter and HTML module to show your result.

<module name="PostProcess" layoutPanel="panel_row1_col1"> <param name="search">eval title="Choose any single Value"|table title</param> 
 <module name="ResultsValueSetter">
              <param name="fields">title </param>
              <module name="HTML" layoutPanel="panel_row2_col1">
                <param name="html">
                  <![CDATA[ <table cellpadding="4" cellspacing="0" style="width: 100%;">
                                          <tr>
                                              <th align="left">
                                                 $title$
                                              </th>
                                          </tr> 
                                   </table>  ]]>
                </param>
              </module>
          </module>

harshal_chakran
Builder

Thanks somesoni2..!!!This worked 🙂

0 Karma
Get Updates on the Splunk Community!

Observability Highlights | January 2023 Newsletter

 January 2023New Product Releases Splunk Network Explorer for Infrastructure MonitoringSplunk unveils Network ...

Security Highlights | January 2023 Newsletter

January 2023 Splunk Security Essentials (SSE) 3.7.0 ReleaseThe free Splunk Security Essentials (SSE) 3.7.0 app ...

Platform Highlights | January 2023 Newsletter

 January 2023Peace on Earth and Peace of Mind With Business ResilienceAll organizations can start the new year ...