Splunk Search

How to plot multiple datasets on the same chart?

GaryZ
Path Finder
I'm trying to implement a chart, so users can select their options from a multi-select input box, and automatically update the chart with the selection the user chose (1 to many).
 
 
 
index=abc dict1
| rename dict1.hardware as hardware, dict1.build as build,
| eval mv=mvappend(“process1", "process2", "process3")
| foreach mode=multivalue mv
     [rename dict1.<<FIELD>>.duration as duration
      | chart avg(duration) OVER build BY hardware
]
 
 
1) Can I have this done in one chart?
2) Can I also have an option to dynamically create multiple charts?
 
TIA.
 
Labels (3)
0 Karma

yuanliu
SplunkTrust
SplunkTrust

Please explain your raw data (best with illustration, anonymize as needed) and your desired output with illustration, then any logic to relate data to desired output if it is not painfully obvious.  I'm pretty sure things are possible.  But it is unfair to expect volunteers to speculate these things because different hypotheses can lead to vastly different paths.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...