Splunk Search

How to join 2 event ID in same index (wineventlog)?

10061987
Engager

Hi all,

I searched my issue on community. There are lots of threads but i couldn't find my issue. As i know i can not see 2 event ID's fields (both of them) in same search because fields are different. I want to see 2 different event ID's fields in same search.

My issue is bit complicated. For this reason i will explain with basic fields and i will change later.

First search:
index=wineventlog EventID=1 process_name=chrome.exe
| stats count by Image process_name process_path CommandLine

Second search:

index=wineventlog EventID=3 DestinationHostname=google.com
| stats count by Image SourceIP DestinationIP DestinationHostname

 

I want join these 2 searches in same search and i want to see 2 different event ID' s fields in same search. I found join command but i couldn't figure out how to use that.

Any help would be appreciated!

Labels (1)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

More words please. You showed two summarizing searches which do not seem to share any fields so it's unclear how you would like to join them. Especially that you wrote about matching events.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...