Splunk Search

How to filter a specific time in Splunk?

sanglap
New Member

I want to perform a search query which can give me results with respective to a specific time.

For example i have a particular time as this:  2022-07-29 18:33:20

My query:

index="*" sourcetype="pan:threat" 10.196.246.104 url=*   earliest=relative_time("2022-07-29 18:33:20","-1h") AND latest = relative_time("2022-07-29 18:33:20","+1h")
| stats values(url) as url by _time,dest_ip,dest_port,app,category,rule,action,user

 

I am not getting appropriate results with this, can anyone suggest how i can do the filtration on the basis of a particular time.

Tags (1)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust
index="*" sourcetype="pan:threat" 10.196.246.104 url=* 
[| makeresults
 | eval earliest=relative_time("2022-07-29 18:33:20","-1h")
 | eval latest = relative_time("2022-07-29 18:33:20","+1h")
 | fields earliest latest]
| stats values(url) as url by _time,dest_ip,dest_port,app,category,rule,action,user
0 Karma

jamie00171
Communicator

Hi @sanglap 

Can you just provide the time like:

earliest="2022-07-29:18:33:20" latest="2022-07-29:18:34:20"

There are some examples here: https://docs.splunk.com/Documentation/SCS/current/Search/Timemodifiers#Examples

Thanks, 

Jamie

 

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk Add-on for Microsoft Windows 11.0.3: Parse Once, Search Faster

The updated Splunk Add-on for Microsoft Windows helps customers search Windows events faster by reducing ...

What's New in Splunk Enterprise Security 8.8 and Beyond

Threats move at machine speed. Keeping up should not depend on having the biggest budget, the largest team, or ...

A Four-Part Event Series: State of Observability - Where AI Meets Performance

As AI agents take on more complex tasks, teams need greater visibility into how they behave, what they cost, ...