Splunk Search

How to compare data from data model with data from data set?

danutmatei
Explorer

Hello, I have a data model named firewall_logs with firewall data in which the interesting fields are: file_hash, url and source/dest IP.

And I have a dataset named intel_indicators with column named ioc in which I have hashes, IPs, domains and timestamp.

 

What I want to do is to compare the data (hashes, IPs, domains) from ioc column with the fields: file_hash, url, dest_ip. If there is a match, it should be visible.

Any ideea how I can accomplish this ?

 

| tstats summariesonly=t allow_old_summaries=t  ...interesting fields.... from datamodel="firewall_logs"  a

and here I'm stuck

Labels (4)
Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Tuning Edge Processor in Hybrid Mode: What Limits Each Data Path

When you run Edge Processor in hybrid mode, alongside a Splunk heavy forwarder on the same host, two questions ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Request for Professional Development: Attending .conf26

Winning Over the Boss: Your Pass to .conf26 conf26 is going to be here before you know it. If don't already ...