Splunk Search

How to cluster in subsearch based on EventCode results returned from main search?

jyim89
New Member

I essentially want to do something like this:

host="*mas*" sourcetype="WinEventLog:Application" AND (Type=Error OR Type=Warning) | foreach EventCode [ search host="*mas*" sourcetype="WinEventLog:Application" EventCode='<<FIELD>>' | cluster ]

However this an error saying "Error in 'foreach' command: Search pipeline may not contain non-streaming commands" It basically doesn't like the cluster command as part of the foreach.

To clarify, I want to cluster based on the EventCodes of the results returned from the initial search. I don't want to cluster on the whole of the initial search itself. Is there an easy way of doing this?

0 Karma

somesoni2
Revered Legend

Try this

host="*mas*" sourcetype="WinEventLog:Application" [search host="*mas*" sourcetype="WinEventLog:Application" AND (Type=Error OR Type=Warning) | stats count by EventCode | table EventCode] | cluster

The subsearch gets all the EventCodes with Type=Error OR Type=Warning and is passed to main search.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Implementing Zero Trust (ZT) across complex environments often falters at the very beginning due to a ...