Splunk Search

How to Root User access?

Taibat02230232
Loves-to-Learn

These are the Splunk query and it seems not working because i cant generate any request from that.

Please I need any help to be able to generate a search.

Any help would be appreciated, thanks

 

index=aws-cloudtrail "userIdentity.type"=Root AND NOT eventType="AwsServiceEvent"
|eval nullParentProcess=if(isnull("userIdentity.invokedBy"),true,false)
|search nullParentProcess=true
|convert ctime(_time) as _time
|stats values(dest) values(eventType) values(eventName) values(userName) latest(_time) by src
|rename values as *
|head 51
Labels (1)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

There are so many things wrong with this search...

But regardless of that, it's hard to say what the proper search should look like without knowing your data. Provide us with a sample of your events (anonymized if needed) and a description of desired results.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Monitoring AI Agents with Splunk Observability Cloud

Let’s say I’m running a travel planning AI app in production. A user asks for three concise hotel options in ...

[Puzzles] Solve, Learn, Repeat: Tiling

This puzzle (first published here) is based on finding groups of tessellated tiles (inspired by floor tiles I ...

SOK it to Me: Top 3 Benefits of Using Splunk Operator on Kubernetes that’ll Make ...

    Thursday, July 9, 2026  |  11:00AM–12:00PM PDT Duration: 1 hour (includes Q&A) Managing can feel like a ...