Splunk Search

How to Root User access?

Taibat02230232
Loves-to-Learn

These are the Splunk query and it seems not working because i cant generate any request from that.

Please I need any help to be able to generate a search.

Any help would be appreciated, thanks

 

index=aws-cloudtrail "userIdentity.type"=Root AND NOT eventType="AwsServiceEvent"
|eval nullParentProcess=if(isnull("userIdentity.invokedBy"),true,false)
|search nullParentProcess=true
|convert ctime(_time) as _time
|stats values(dest) values(eventType) values(eventName) values(userName) latest(_time) by src
|rename values as *
|head 51
Labels (1)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

There are so many things wrong with this search...

But regardless of that, it's hard to say what the proper search should look like without knowing your data. Provide us with a sample of your events (anonymized if needed) and a description of desired results.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI + Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...

Splunk Technical Support Is Moving to Cisco Support Tools

Introduction Splunk technical support is transitioning to Cisco’s support environment. This change brings ...