Splunk Search

How do you filter data for just one index when index=*?

wvalente
Explorer

Guys,

I have the query with index=te*. I need this search in this form. I cannot change for separated index.

my search is:

index=te* source=Win* OR source=win* user=Admin* NOT user=*$  EventCode=4625 OR EventCode=4624
| table index _time user src host src_ip name

I need to filter a user=Administrator that appears in just one of these indexes.

How can I do that?

Thanks.

0 Karma

FrankVl
Ultra Champion

Your question is not very clear. Perhaps you can share some sample output of the search you have right now and then give an example of what it should be.

It is not clear to me whether you want to filter out a certain index, or whether you want to look for user=Administrator that occurs only in one (not a specific one, but once) index?

0 Karma

DMohn
Motivator

You could try it this way:

(index=te* NOT index=te_yourindex source=Win* OR source=win* user=Admin* NOT user=*$) OR (index=te_yourindex user=Administrator) EventCode=4625 OR EventCode=4624
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...