Splunk Search

How do I sort this stats count?

bayman
Path Finder

This is my search below. It shows Country and count. How do I sort the count field for largest to smallest?

index="cisco_asa" src_ip="*" dest_port="*" action="blocked" | fields src_ip | iplocation src_ip | stats count by Country

kmorris_splunk
Splunk Employee
Splunk Employee

Add the following to the end of your search:

your search....| sort -count

woodcock
Esteemed Legend

Because there are fewer than 1000 Countries, this will work just fine but the default for sort is equivalent to sort 1000 so EVERYONE should ALWAYS be in the habit of using sort 0 (unlimited) instead, as in sort 0 - count or your results will be silently truncated to the first 1000.

DavidHourani
Super Champion

Just an update, default is now 10000 now 1000

dstaulcu
Builder

This is one of the most common gotchas I see among our users. Sure wish splunk would add some sort of tool tip or notification when such limits kick in.

santiagoaloi
Path Finder

that's a good one to keep in mind!

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Catalog Is Now Generally Available on Splunk Cloud Platform

A Unified View of Your Data  Security logs, application events, business data, and historical telemetry often ...

Developer Spotlight with Eduard Lekanne

From Network Engineer to Building Agentic AI for Splunk Eduard Lekanne has been architecting technology ...

From Data Landing to Insight

Search Across More of Your Data Ecosystem The data you need may live in Splunk, high-volume machine data, ...