Splunk Search

How do I get unique within each group?

msg4sunil
Path Finder

Team,

Can you please help me with the splunk query for the below?

Thank you

Splunk query returns the below

1
1
1
2
2
2
3
1
1
3
1

How do I get the below( unique within each group)?

1
2
3
1

 

0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust
index=*
| table sourcetype
| streamstats current=f window=2 last(sourcetype) as previous_sourcetype
| where sourcetype != previous_sourcetype

View solution in original post

ITWhisperer
SplunkTrust
SplunkTrust

How did you get this result?

Why is 1 still repeated in your required result?

0 Karma

msg4sunil
Path Finder

Since I wanted to know the flow of data from one sourcetype to another sourcetype.  Apparently, in my case, the data after existing a sourcetype can re enter the sourcetype at a later point of time.

Thank you

0 Karma

SanjayReddy
SplunkTrust
SplunkTrust

Hi @msg4sunil 

use

values(fieldname1) by fieldname2

0 Karma

msg4sunil
Path Finder

@SanjayReddy 

Can you please clarify as how do I use 

values(fieldname1) by fieldname2?

 
My original query is 
index=*|table sourcetype
 
Thank you
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust
index=*|table sourcetype|dedup sourcetype
0 Karma

msg4sunil
Path Finder

Sorry, I cant be using dedup, since that doesn't solve my purpose.

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust
index=*
| table sourcetype
| streamstats current=f window=2 last(sourcetype) as previous_sourcetype
| where sourcetype != previous_sourcetype

msg4sunil
Path Finder

Wow. Amazing. Thanks a lot!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...