Splunk Search

Help with search using eval and table?

oh_sechang
New Member

 

 

index="hx_vm" LogName="Microsoft-Windows-Sysmon/Operational" "EventCode=11" ComputerName=DESKTOP-933JR8B
| eval {name} = replace("C:\Windows\SysWOW64\OneDriveSetup.exe","\", "\\")
| search Image = name
| table _time, TargetFilename

 

 

The variable usage part is difficult.

Labels (3)
0 Karma

yuanliu
SplunkTrust
SplunkTrust

Where is the question?  Three detail you need in a post: how does the data look like, what is it that you expect as result, what is the logic between data and expected result; if you post sample code, explain the result you get and why it doesn't meet requirements.

Looking at your sample code, I guess you do not mean | search Image = "name", because that's exactly what the code means.  Anything on the right of an equal sign  in a search command is a string.  Try

index="hx_vm" LogName="Microsoft-Windows-Sysmon/Operational" "EventCode=11" ComputerName=DESKTOP-933JR8B
| eval name = replace("C:\Windows\SysWOW64\OneDriveSetup.exe","\", "\\")
| where Image == name
| table _time, TargetFilename

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Implementing Zero Trust (ZT) across complex environments often falters at the very beginning due to a ...