Splunk Search

Help with search using eval and table?

oh_sechang
New Member

 

 

index="hx_vm" LogName="Microsoft-Windows-Sysmon/Operational" "EventCode=11" ComputerName=DESKTOP-933JR8B
| eval {name} = replace("C:\Windows\SysWOW64\OneDriveSetup.exe","\", "\\")
| search Image = name
| table _time, TargetFilename

 

 

The variable usage part is difficult.

Labels (3)
0 Karma

yuanliu
SplunkTrust
SplunkTrust

Where is the question?  Three detail you need in a post: how does the data look like, what is it that you expect as result, what is the logic between data and expected result; if you post sample code, explain the result you get and why it doesn't meet requirements.

Looking at your sample code, I guess you do not mean | search Image = "name", because that's exactly what the code means.  Anything on the right of an equal sign  in a search command is a string.  Try

index="hx_vm" LogName="Microsoft-Windows-Sysmon/Operational" "EventCode=11" ComputerName=DESKTOP-933JR8B
| eval name = replace("C:\Windows\SysWOW64\OneDriveSetup.exe","\", "\\")
| where Image == name
| table _time, TargetFilename

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

From Raw Data to Executive-Ready Stories, Faster

Build Data Stories for Every Audience  A dashboard is rarely just a dashboard. It might be the view an ...

Guided Onboarding with Auto-schema Is Now Generally Available

  We are excited to announce the General Availability of Guided Onboarding with Auto-Schematization ...

ATTENTION: We’re Moving! (AGAIN!)

The Splunk Community Slack is undergoing a system migration to keep our workspace secure and ...