Splunk Search

Help with SPL for report generation?

LogUx
Motivator

Hello Splunkers!!

I need the results as per the below format. I have tried some SPL but not achieved with the expected results. Please help me to achieve the same.

  Order Status AU NZ UK
02:00:00 created. 10 11 12
  released 9 8 6
  shipped 6 7 4
         
    AU NZ UK
03:00:00 created. 10 11 12
  released 9 8 6
  shipped 6 7 4


What I have done so far In SPL :

index="ABC "OrderStatus=created" OR "OrderStatus=Shipped" OR "OrderStatus=Released" OR "OrderStatus=Cancelled"
| rex field=_raw "SellerOrganizationCode\=one\_(?<Market>[A-Z]{2})"
| search NOT (Market="CA" OR Market="US" OR Market="KO" OR Market="SE" OR Market="NL" OR Market="IE" OR Market="NO" OR Market="LA")
| replace CH WITH EU GB WITH UK
| bin _time span=1h
| eval Time=strftime(_time,"%m/%d-%y %H:%M:%S.%Q %p")
| eval newtime=strptime(Time,"%m/%d-%y %H:%M:%S.%Q %p")
| eval Time_Hour=strftime(newtime,"%m/%d/%Y %H:%M")
| chart count by Time_Hour,Market usenull=f
| addtotals col=true row=true label=Total labelfield=Time_Hour
| rename Total as "Total orders for the hour"
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...