Splunk Search

Haversine Issue

genesiusj63
Explorer

Hello, 

I am working with a GPX file and installed the haversine app to calculate the distance between lat/lon coordinates in each event. This is the latest 

index="gpx" source="11.22.20-Long-7.5.gpx"
| eval tlat='trkpt{@lat}' | eval tlon='trkpt{@lon}'
| haversine originfield="tlat,tlon" outputField=d lat lon
| table trkpt.time, trkpt{@lat}, lat, trkpt{@lon}, lon, d, trkpt.ele

I know I am missing something so minor, but I can't see it.

Thanks in advance for any assistance you can provide here.

Safe and healthy to you and yours.
Happy and Blessed Thanksgiving,
Genesius

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...