Splunk Search
Highlighted

Geostats zoom level

Communicator

I am attempting to use geostats to map events per city in my dashboard. Once I zoom to a certain level the map vanishes. Has anyone experienced this and know the solution. My dash looks like this:

<dashboard>
  <label>Mapped Yesterday</label>
  <description>Map from yesterday</description>
  <row>
    <map>
      <title>Mapped Yesterday</title>
      <searchString>index=myindex |geostats count by City globallimit=0</searchString>
      <earliestTime>-1d@d</earliestTime>
      <latestTime>@d</latestTime>
      <option name="mapping.map.fitBounds">(40.58,-73.44,42.3,-71.47)</option>
     <option name="mapping.map.zoom">7</option>
      <option name="mapping.tileLayer.maxZoom">18</option>
      <option name="mapping.data.maxClusters">1000</option>
    </map>
  </row>
</dashboard>
Tags (2)
0 Karma
Highlighted

Re: Geostats zoom level

Splunk Employee
Splunk Employee

It looks as if your initial zoom level is set to 7, which is the default maximum zoom level. I don't think there are tiles included in the product for zoom levels beyond seven. For more detailed tiles, you would have to connect to an external tile server, using mapping.tileLayer.url. See the simple XML reference for map.

View solution in original post

Highlighted

Re: Geostats zoom level

Communicator

Thanks. Adding that option did the trick.

0 Karma
Highlighted

Re: Geostats zoom level

Contributor

This app will be helpful:
https://splunkbase.splunk.com/app/3124/

0 Karma