Splunk Search

Geostats is not working in 6.3



I have a lookup table in which I have area code and longtitue and latitude and other details, at the other end I have area code in my index also.

So, I have made my query with lookup table to match for all the area code and show a "MAP" graph.

I am doing ..

index=indexname areacode | lookup coordinate.csv areacode as CCC | geosats global....=0 latfi....=latitute long...=longitude count by CCC

My output is having something like this :

geobin longitue latitue 200 201 202 304 501 505
blahblah blah -blah 1 1 1 4 1

now, the problem is in my result set only 6 area code is showing 200 201 202 304 501 505 ( just as above example ) , Even though I have more data matching up with lookup table, those Areacodes are not showing, like it is not showing 210 , 312 area code.

Please help me why I can't see these area codes in the statistics even though I have data for these two.


Tags (1)
0 Karma



OTHER values show up due to global limits for geostats command. You can get rid of it setting globallimit=0. Then it will show up all values found.

0 Karma


Hi, can you provide example events for all area codes? Also provide the lookup file.
How is this area code field created? If by using field extraction, does the regex match all area codes?

cheers, MuS

0 Karma
Get Updates on the Splunk Community!

Splunk Life | Happy Pride Month!

Happy Pride Month, Splunk Community! 🌈 In the United States, as well as many countries around the ...

SplunkTrust | Where Are They Now - Michael Uschmann

The Background Five years ago, Splunk published several videos showcasing members of the SplunkTrust to share ...

Admin Your Splunk Cloud, Your Way

Join us to maximize different techniques to best tune Splunk Cloud. In this Tech Enablement, you will get ...