Splunk Search

Find values for specific distinct counts

mztopp
Explorer

Hello all!

I was hoping to take a distinct count and show either the count, or if the count is 1, show the value that is being counted. For example, index=random | stats dc(src_port) AS port_count count by src_ip would populate:

src_ip    |      port_count

-----------------------------------------------------

1.2.3.4             6

2.3.4.5             (1) Port 443

3.4.5.6              4

 

Or something to this effect. Thanks!

Labels (3)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

There may be a few ways to do that.  Here's one.

index=random 
| stats values(src_port) AS ports count by src_ip 
| eval port_count = if(mvcount(ports)==1,"(1) Port " . mvindex(ports,0), mvcount(ports))
---
If this reply helps you, Karma would be appreciated.

View solution in original post

0 Karma

richgalloway
SplunkTrust
SplunkTrust

There may be a few ways to do that.  Here's one.

index=random 
| stats values(src_port) AS ports count by src_ip 
| eval port_count = if(mvcount(ports)==1,"(1) Port " . mvindex(ports,0), mvcount(ports))
---
If this reply helps you, Karma would be appreciated.
0 Karma

mztopp
Explorer

Thank you!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Catalog Is Now Generally Available on Splunk Cloud Platform

A Unified View of Your Data  Security logs, application events, business data, and historical telemetry often ...

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner   Watch on demand us for a demo-driven ...