Splunk Search

Filter away pattern on windows event log report

keyu921
Explorer

Current report for the following event log

index=windows  EventType=4 host=* | table _time host EventCode Message

///

EventType=4
Type=Information
ComputerName=NOYO.asus.com
Message=Installation Successful: Windows successfully installed the following update: Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 (Version 1.323.1450.0)

//

I try to filter away if event if message contains Security Intelligence Update for Microsoft Defender Antivirus

index=windows  EventType=4 host=*  
| where Message="%Security Intelligence Update for Microsoft Defender Antivirus%"
| table _time host EventCode Message

But seems message cannot filter

Labels (1)
0 Karma

thambisetty
SplunkTrust
SplunkTrust

Where command is used to compare two field values or check if field value is less or greater than a given number.

read about where and search commands in search reference.

https://docs.splunk.com/Documentation/Splunk/8.0.6/SearchReference/Where

 

————————————
If this helps, give a like below.
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @keyu921,

please try this:

index=windows  EventType=4 host=* Message="*Security Intelligence Update for Microsoft Defender Antivirus*"
| table _time host EventCode Message

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk Add-on for Microsoft Windows 11.0.3: Parse Once, Search Faster

The updated Splunk Add-on for Microsoft Windows helps customers search Windows events faster by reducing ...

What's New in Splunk Enterprise Security 8.8 and Beyond

Threats move at machine speed. Keeping up should not depend on having the biggest budget, the largest team, or ...

A Four-Part Event Series: State of Observability - Where AI Meets Performance

As AI agents take on more complex tasks, teams need greater visibility into how they behave, what they cost, ...