Splunk Search

Export csv data to specific folder

Learner
Path Finder

Hi everyone, below is my sample query

 

index=xyz source=ABC | stats count

 

If I schedule this search then result have to saved on path "C:\\demo" automatically. I don't have access to \var repository so cannot make changes over there. I'm using windows OS. How i can get the data on path automatically? 

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @Learner,

you have two solutions:

  • a scheduled script that moves the files from var/run/splunk/csv to another folder;
  • modify the python script that creates the csv.

The second is really difficoult, but the first it's easy.

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...