Splunk Search

Error: mvexpand output will be truncated due to excessive memory usage

erstexas
Path Finder

I get the above error when running a query. I have increased the RAM and swap space on the system and I still get the error. Are there internal controls for this that I could adjust? I can confirm that Splunk is nowhere near running out of memory and not sure how to fix this so that the results are not truncated.

Tags (3)
1 Solution

khourihan_splun
Splunk Employee
Splunk Employee

Howdy Tex!

Check out http://docs.splunk.com/Documentation/Splunk/5.0.3/Admin/Limitsconf and check out the max_mem_usage_mb = setting.

You can increase the size to handle larger mvexpand results. Just be sure to make sure you have enough free RAM for the size you choose.

best,
Kyle

View solution in original post

khourihan_splun
Splunk Employee
Splunk Employee

Howdy Tex!

Check out http://docs.splunk.com/Documentation/Splunk/5.0.3/Admin/Limitsconf and check out the max_mem_usage_mb = setting.

You can increase the size to handle larger mvexpand results. Just be sure to make sure you have enough free RAM for the size you choose.

best,
Kyle

erstexas
Path Finder

You know, I actually looked through that file and didn't see anything that sounded interesting to fix this. I did not find the above online doc listing it as an optional setting. Thanks. I will experiment with this setting.

0 Karma
Get Updates on the Splunk Community!

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...

Introducing the Splunk Community Dashboard Challenge!

Welcome to Splunk Community Dashboard Challenge! This is your chance to showcase your skills in creating ...