Splunk Search

Error during Python init in custom search commands

seva98
Path Finder

Hi,

I believe that my Splunk's Python has some issue during initialization. This happens whenever I try to run any of many searches that includes Custom Search Commands. Python scripts in CSCs are ok as they run without issue on other computers.

Error in 'script': Getinfo probe failed for external search command 'detailmodel'
^
raise CodecRegistryError,\
File "C:\Program Files\Splunk\Python-2.7\Lib\encodings\__init__.py", line 123
Current thread 0x000037c0 (most recent call first):
Fatal Python error: initfsencoding: unable to load the file system codec
SyntaxError: invalid syntax
0 Karma
1 Solution

seva98
Path Finder

Issue was caused by installing Anaconda which had its own Python and somehow messed up configurations of Splunk's Python. Uninstalling Anaconda and rewriting env variables didn't helped.

At the end, I just decided to reinstall Splunk while making sure I have removed all other Python installations before doing so and it made Splunk's Python work again.

View solution in original post

0 Karma

seva98
Path Finder

Issue was caused by installing Anaconda which had its own Python and somehow messed up configurations of Splunk's Python. Uninstalling Anaconda and rewriting env variables didn't helped.

At the end, I just decided to reinstall Splunk while making sure I have removed all other Python installations before doing so and it made Splunk's Python work again.

View solution in original post

0 Karma

to4kawa
SplunkTrust
SplunkTrust

Please provide your way or answer below Question.
I am seeking it.

https://answers.splunk.com/answers/816567/splunk-python-with-pandas.html

0 Karma

DavidHourani
Super Champion

Hi @seva98, did this happen after an upgrade or something or has this always been happening ?

0 Karma

seva98
Path Finder

Hi @DavidHourani the issue was with Anaconda's Python. It was extra Python that somehow reconfigured Splunk's Python and Splunk had issue recognizing correct Python even after uninstall of Anaconda and setting env variables. Reinstalling Splunk solved the issue.

0 Karma

DavidHourani
Super Champion

ah that's great, please answer your post and accept your answer for future reference ! 🙂

0 Karma

seva98
Path Finder

@DavidHourani Will do 🙂

0 Karma