Splunk Search

Does Splunk do Internet Name Resolution?

garciatdg
New Member

I am doing an experiment at home to capture Internet traffic for all of my devices in my house connected to my home wi-fi. I heard in a conference that a guy setup Splunk Streaming on his splunk instance and was able to capture all traffic between his wireless router and any device in his house.

sourcetype="stream:ip" src_ip="192.168.1.16"
| stats count by dest_ip

I put this quick query together but I don't think I'm capturing everything, but I'd also like to have splunk resolve the Dest_IP
For example, if I pull up Google.com, I'd like to see in a Splunk Table "google.com" and not "172.217.5.78"

my results are as follows

alt text

Tags (1)
0 Karma

woodcock
Esteemed Legend

Yes, assuming DNS is accessible by the search head, just add this to the bottom:

... | lookup dnslookup clientip AS dest_ip
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...

SplunkTrust Application Period is Officially OPEN!

It's that time, folks! The application/nomination period for the 2026-2027 SplunkTrust is officially open. If ...