Splunk Search

Diff Nessus Reports

leunammejii
New Member

I'm trying to compare two monthly Nessus reports using Splunk with the following command:

sourcetype="nessus:scan" name=REPORT_NAME earliest=-1mon@mon latest=@mon NOT severity=informational NOT [search sourcetype="nessus:scan" name=REPORT_NAME earliest=-2mon@mon latest=-1mon@mon NOT severity=informational | dedup plugin_id,host-fqdn | table host-fqdn,name,operating-system,plugin_id,plugin_name,policy,severity,severity_index] | dedup plugin_id,host-fqdn | table host-fqdn,name,operating-system,plugin_id,plugin_name,policy,severity,severity_index | stats count by severity

I get results but I get them almost 15 minutes later. The search head has the recommended resources but it is still slow as a snail. What am I doing wrong?

I've also tried the following but it only compares the first event:

[search sourcetype="nessus:scan" name=REPORT_NAME earliest=-1mon@mon latest=@mon NOT severity=informational | dedup plugin_id,host-fqdn | table host-fqdn,name,operating-system,plugin_id,plugin_name,policy,severity,severity_index] [search sourcetype="nessus:scan" name=REPORT_NAME earliest=-2mon@mon latest=-1mon@mon NOT severity=informational | dedup plugin_id,host-fqdn | table host-fqdn,name,operating-system,plugin_id,plugin_name,policy,severity,severity_index] | diff maxlen=0

0 Karma

sundareshr
Legend

See if this helps

sourcetype="nessus:scan" name=REPORT_NAME NOT (severity=informational) earliest=-2mon@mon  | eval when=if(_time>relative_time(now(), "-1mon@mon"), "Current", "Previous") | eval h=host-fqdn."#".name | chart count over h by when | rex field=h "(?<host-fqdn>[^#]+)#(?<name>.*)" | fields - h
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...