Splunk Search

Data model in custom search

SIEMStudent
Path Finder

Hi all,

I have a doubt regarding the datamodel use.

In Splunk Foundamentals 2 course, I got what Data Models is and how to use it with Pivot.

My doubt now is the following: is it possible to use a datamodel and its field in a custom search, for example in the Search and Reporting app? And if yes, how?

Suppose I have to perform a simple search like this one on network traffic:

index=<some index> sourcetype=<some_sourcetype>| stats count src as source by dest as destination

Suppose now I want to use Network Traffic Data model and its Data set All_Traffic to perform this search, to avoid the use of index and sourcetype; is this possible? And if yes, how to perform this search?

Labels (2)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

There are a couple of ways to do that (and perhaps others).

The fastest is to use the tstats command.

| tstats count(foo.src) as source from datamodel=foo by foo.dest
| rename foo.dest as destination

The other method uses the from command.

| from datamodel foo | stats count(src) as source by dest 
| rename dest as destination

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

There are a couple of ways to do that (and perhaps others).

The fastest is to use the tstats command.

| tstats count(foo.src) as source from datamodel=foo by foo.dest
| rename foo.dest as destination

The other method uses the from command.

| from datamodel foo | stats count(src) as source by dest 
| rename dest as destination

 

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...