Splunk Search

Count elements from every percentile

kp_pl
Path Finder

My target is not only show proper percentiles but also count elements in every precentile . So the first step I did is:

index="oap"
| stats perc25(tt) as P25,
             perc50(tt) as P50,
             perc75(tt) as P75 by oper


It gives me expected values for each percentile - the first part is ready.
Then I figured out something like

| where tt>P75
| stats values(P75) count by oper


It adds additional column but only with data from one (75th) percentile. But how to prepare a query which returns count for each Percentil ?

 

Labels (1)
0 Karma

yuanliu
SplunkTrust
SplunkTrust

Instead of stats, use eventstats.

index="oap"
| eventstats perc25(tt) as P25,
             perc50(tt) as P50,
             perc75(tt) as P75 by oper
| foreach P25 P50 P75
  [eval <<FIELD>>count = if(tt><<FIELD>>, 1, 0)]
| stats values(P*count) as P*count by oper P25 P50 P75
Tags (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @kp_pl ,

sorry but I don't understand your request:

perc75(tt) is one of the calculated values, so why do you want to add a new column?

Could you share how you are waiting for results?

Ciao.

Giuseppe

0 Karma

kp_pl
Path Finder

Ok, will try to expain it ....

 

there are thousand of digits, of course values can repeat.

So first I want to  divide them ( in that case) into quartile. In my case : 0-25, 25-50, 50-75,75-100. Then , and this is my problem, count how many values has every section/quartile. In my case I need 4 pairs : value<>quantity. 

Is it more clear ... 

 

 

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...