Splunk Search

Comparing individual values with the past average

MidnightRun
Explorer

I have a search query that looks like this:

 

index="myindex" sourcetype="mysource" earliest=@d latest=now  
| append [ search index="myindex" sourcetype="mysource" earliest=-1mon@mon latest=@mon 
| stats avg(Price) as past_avg by ID ] 
| stats values(*) as * by ID
| table Date, ID, Price, past_avg

This gives me:

Screenshot_1.png

what I'm trying to do is display only those values in the Price column that are smaller then past_avg,  does anyone know how I could achieve that?

0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust

You could use mvfilter - the problem with this is that you can only reference the mv field, so you could concatenate the average, then in the filter split the two parts for the comparison, then remove the average

| eval price=mvmap(price,price."|".past_avg)
| eval price=mvfilter(mvindex(split(price,"|"),0)<mvindex(split(price,"|"),1))
| eval price=mvmap(price,mvindex(split(price,"|"),0))

Alternatively, you could do the comparison before the stats

| eventstats values(past_avg) as past_avg by id
| where price < past_avg
| stats values(*) as * by id

View solution in original post

ITWhisperer
SplunkTrust
SplunkTrust

You could use mvfilter - the problem with this is that you can only reference the mv field, so you could concatenate the average, then in the filter split the two parts for the comparison, then remove the average

| eval price=mvmap(price,price."|".past_avg)
| eval price=mvfilter(mvindex(split(price,"|"),0)<mvindex(split(price,"|"),1))
| eval price=mvmap(price,mvindex(split(price,"|"),0))

Alternatively, you could do the comparison before the stats

| eventstats values(past_avg) as past_avg by id
| where price < past_avg
| stats values(*) as * by id
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...