Splunk Search

Combination of uri patterns

xvxt006
Contributor

Hi,

i would like to capture the below 2 patterns and i tried to use the below combination but i am not getting intended results. Can someone help

/product/Dsdhty-wetds-Cartridge-3456er?s_pp=false

/search?searchQuery=1DAH1

Tried this..
| (uri=/product/* OR regex uri="/search\?searchQuery=\w{5}$")

Tags (1)
0 Karma

lukejadamec
Super Champion

You're missing a slash before the w.

\w{5}$

Well, I don't think you can use an OR with a regex, and a subsearch won't work. You can append the results. Here is an example for pulling two series of EventCodes.

index=main EventCode="5*" |stats count by EventCode |append [search index=main EventCode="*" | regex EventCode="^4\d+" |stats count by EventCode]
0 Karma

lukejadamec
Super Champion

I updated the answer with an example of append.

0 Karma

lukejadamec
Super Champion

Highlight the string and click the 101010 format option to capture the special characters.

0 Karma

xvxt006
Contributor

Actually for some reason it is not showing the backslash when i put it but i do have it in my query 🙂

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...