Splunk Search

Check events in time

noott211
Path Finder

index="fw" app="ping"
| bin _time span=10m
| stats count by client_ip,dest_ip
| stats list(dest_ip) AS dest_ip , list(count) AS count by client_ip
| table client_ip , dest_ip , count


I'd like to check the origin IP and destination IP that I pinged 10 times in 10 minutes.
However, this command calculates the number of times for all times.
Give me a hand with this.

Labels (1)
Tags (2)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust

You need to include _time in the stats commands

index="fw" app="ping"
| bin _time span=10m
| stats count by _time,client_ip,dest_ip
| stats list(dest_ip) AS dest_ip , list(count) AS count by _time,client_ip
| table _time, client_ip , dest_ip , count

View solution in original post

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

You need to include _time in the stats commands

index="fw" app="ping"
| bin _time span=10m
| stats count by _time,client_ip,dest_ip
| stats list(dest_ip) AS dest_ip , list(count) AS count by _time,client_ip
| table _time, client_ip , dest_ip , count
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...

Where Innovation Takes Flight: The Splunk4Aviation Flight Sim Lands at .conf26

If you hear someone at .conf26 shouting "gear down, GEAR DOWN" across the show floor, you have found us.  The ...