Splunk Search

Can't connect to SQLite database

responsys_cm
Builder

I'm using the DB Connect V1 app in Splunk 6.2 on an Ubuntu Linux server. I have a local sqlite database. I can use the sqlite3 command to connect to it successfully.

I've created a database connection that looks like:

[vFeed]

database = /opt/vFeed/vfeed.db
host = localhost

isolation_level = DATABASE_SETTING

type = sqlite

disabled = 0
username = root

When I try and browse the schema, I get the following error:

The internal search "| dbinfo database="vFeed" type=schemas | sort -default | eval label=if(isnull(default),schema,schema+" (default)")" for the "Splunk.Module.SearchSelectLister" module failed.

I'm not seeing any error messages.

What am I doing wrong here?

Thx.

Craig

Tags (1)
0 Karma

responsys_cm
Builder

The database file is vfeed.db. Renaming it vfeed.sqlite and placing it in the /opt/splunk/var/dbx folder solved the problem.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...