Splunk Search

COALESCE command

jip31
Motivator

hi
when I execute the query below

index="x" sourcetype="WinEventLog:Microsoft-Windows-Diagnostics-Performance/Operational"

I can display a field called "OpCode". This fields has many values and I want to display one of them
sometimes this field is in english, sometimes in french, sometimes in spain and sometimes in german
so I need to use "coalesce" like this

| eval 'Boot_Degradation'=coalesce('Boot_Degradation','Détérioration du démarrage','Información del arranque','Startbeeinträchtigung') 
| table OpCode

but it doesnt works
could you help me please???

Tags (1)
0 Karma

vnravikumar
Champion
0 Karma

gouravdashtcs
Loves-to-Learn

Hello Jip31,

Coalesce command is used to combine two or different fields from different or same sourcetype to perform further action.

Kindly try to modify the above SPL and try to run.

| eval 'Gen_OpCode'=coalesce('Boot_Degradation','Détérioration du démarrage','Información del arranque','Startbeeinträchtigung')
|table Gen_OpCode

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Preparing your Splunk Environment for OpenSSL3

The Splunk platform will transition to OpenSSL version 3 in a future release. Actions are required to prepare ...

Self-Healing Pipeline Is Now Generally Available: AI-Powered CIM Compliance

Maintaining data integrity across security and analytics pipelines is an ongoing challenge. Data ...

[Puzzles] Solve, Learn, Repeat: Family Trees

This puzzle (first published here is based on finding grandparents and grandchildren (inspired by a question ...