Splunk Search

Bar chart width resize in Simple XML

dinesh_wadhwa
Engager

Hello,

I have created a vertical bar chart using Simple XML, My requirement is to fix the width of all the bars. I am using "5", but its not working in the below code. Please suggest

index= abc| stats count by Product


right
ellipsisMiddle
0
all
shiny
default
0.01
gaps
column
inherit
1
linear
linear
visible
visible
visible
0
ellipsisNone

Tags (5)
0 Karma

yvassilyeva
Path Finder

See if solution by @niketn helps. After your <panel> add this:

 .facets-container .viz-facet {
          height: 100px !important;
          width: 100px !important;
          float: left;
          padding: 10px 0px 0px 0px;
      } 

 

Also see his response here:
https://community.splunk.com/t5/All-Apps-and-Add-ons/Using-trellis-with-simple-XML-extension/m-p/367...

0 Karma

harshal_chakran
Builder

I guess in Advance XML you can do this.

Use this line

<param name="charting.chart.columnStyle.width">5</param>

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...