Splunk Search

Alert on top source and destination IPs when result count greater than 100,000

jwelsh123
New Member

I'd like an alert that runs against ASA firewall logs and shows the top 20 source addresses and top 20 destination addresses in a single search if possible. Conversation pairs dont matter, just top 20 source ips and top 20 dest ips. And if its too much trouble to split out source and destination then simply counting how many times an IP shows up as either source or destination would suffice.

I can get it to work with two different alerts if I use the search strings below, but ideally it would be a combined alert.

index=x host=x | stats count by dest_ip | eventstats sum(count) as total_count | sort by -count| head 20 | where total_count > 100000
index=x host=x | stats count by src_ip | eventstats sum(count) as total_count | sort by -count| head 20 | where total_count > 100000

Alert configured to trigger if result count > 1

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...