Splunk Search

How to create a search for Account Creation Event ID 4720?

lsufan861
New Member

I'm a novice user to Splunk and need a simple index search for account creation, time, and creator.  I'm on  closed domain and don't have the typical add ons.  Thank you in advance.

Labels (1)
Tags (1)
0 Karma

General_Talos
Path Finder

Try this if this helps

 

index=* source="WinEventLog:Security" (EventCode=4720 OR EventCode=624)
    | eval CreatedBy = mvindex(Account_Name,0) 
    | eval New_User = mvindex(Account_Name,1) 
    | search CreatedBy=*
    | table _time EventCode CreatedBy New_User

cwheeler33
Explorer

this post saved me so much time!!!
Thank you

note1: Only need EventCode=624 if you have Windows 2008 or older systems.
note2: don't need this line, but the rest is perfect.

| search CreatedBy=*

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Character substitutions with Regular Expressions

This challenge was first posted on Slack #puzzles channelFor BORE at .conf23, we had a puzzle question which ...

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...