Splunk SOAR

PostgreSQL app fails to connect. SCRAM authentication requires libpq version 10 or above

Iñigo
Explorer

Hi

We are being unable to use the PostgreSQL connector since updating to SOAR version 6, either with the last connector version or with previous the ones.

This issue is happening both on cloud environments and on-prem environments (which where connecting ok to PostgreSQL while on Phantom 5.X versions).

This is the error we are getting on-prem (the very same happens on cloud enviroments with automation broker).

 
Testing Connectivity

App 'PostgreSQL' started successfully (id: 1723042384532) on asset: 'pgdb'(id: 433)
Loaded action execution configuration
db login error
SCRAM authentication requires libpq version 10 or above
Test Connectivity Failed. PostgresqlConnector::initialize() returned error.

I already opened a suport ticket weeks ago but maybe some of you were able to solve it on your own.

Any ideas about the root cause and possible solutions?

Regards

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...