Splunk Enterprise

What does the "TypeError: 'NoneType' object is unsubscriptable" error mean on IE?

BunnyHop
Contributor

I'm having an access issue with Splunk for IE8. The error message is

TypeError: 'NoneType' object is unsubscriptable

Anybody familiar with this issue?

Tags (1)
0 Karma
1 Solution

BunnyHop
Contributor

Theoretically, this is not a Splunk issue (in my case) but a very distinct behavior in the environment.

View solution in original post

0 Karma

BunnyHop
Contributor

Theoretically, this is not a Splunk issue (in my case) but a very distinct behavior in the environment.

View solution in original post

0 Karma

dclick
New Member

update what version solves it please?

0 Karma

krotik
New Member

update version solves it

0 Karma

gzimmerer
New Member

In my case this appeared to be caused when going from the full evaluation license to the Free license.

It resolved when I cleared cache and refreshed my browser.

SOLVED?!?

0 Karma

BunnyHop
Contributor

This was actually solved by re-creating the profile for the IE user. This sounds convoluted but Splunk was installed on a server and being hosted through Microsoft's RemoteApp. So essentially, the profile is created on the RemoteApp side, therefore showing the same error regardless of which user is logged on. Needless to say, to has been resolved.

0 Karma

cfergus
Path Finder

The problem is not IE specific.

In our case, we put an app out with just a default directory, which contained indexes, app, props, and transforms.conf.

When you try to view this app, the "TypeError" is rendered. We get this error using Firefox 3.5. Seems to be related to something in the rendering of the page.

cfergus
Path Finder

Another developer took over this and I can relay the current status.
The 'is_visible' property is present, and a default nav is in place. The error is no longer appearing, so your response (gkanapathy) seems to address the problem.

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

Do you also have a default Nav for your application? This error comes up if you try to do certain things in the UI and there is not a default nav and the corresponding default view. I think it might also come up if your is is not marked is_visible regardless.

Johnvey
Contributor

Ah, if that's the case, we'll need more info. Check the web_service.log file for a stack trace so we can diagnose. Or if you prefer, run a splunk diag and open a support case to get official tracking.

Johnvey
Contributor

That is a generic IE error that isn't terribly useful by itself. Unfortunately, debugging IE requires special tools to be installed, so the best place to start is to outline the steps you took that generated that error so that we can reproduce it in-house.

0 Karma

rroberts
Splunk Employee
Splunk Employee

Ive seen this when an app has no default view. What app are you using?

0 Karma

BunnyHop
Contributor

I'm seeing this on IE only, mostly when you browse on the actual server where splunk is installed, winserver 2008 R2.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!