Splunk Enterprise

Use eval field inside append search

mad_splunker
New Member

Hello Splunkers,

I am trying below query -

 

index=someindex cluster=gw uuid=gw98037234c6e51a48816016172b8a3c56
| eval api_uuid="gw"+reqid
| head 1
| append [search index=someindex cluster=api uuid=api_uuid]

 

Basically what I am trying is to get result from first search, evaluate new field from first search and add it as condition to second search. It is not working if I supply api_uuid field but If I replace uuid in append with actual computed value it is returning proper result. I have seen few people using join but dont want to use join as its expensive and comes with limit. Any solution to above query ?

Labels (1)
Tags (2)
0 Karma

mad_splunker
New Member

Nope not working

0 Karma

kamlesh_vaghela
SplunkTrust
SplunkTrust

@mad_splunker 

index=someindex cluster=api uuid=api_uuid [ search index=someindex cluster=gw uuid=gw98037234c6e51a48816016172b8a3c56 | eval uuid="gw"+reqid  | table uuid ]

 

Can you please try this? I have used different approach. 

 

thanks

KV

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...