Splunk Enterprise

Search without index not working

lucas4394
Path Finder

I installed the latest version of Splunk on my local machine and play around. I created a index with various sourcetypes, but search doesn't work without index specified. I saw another post here, https://answers.splunk.com/answers/71694/search-without-index-not-working.html, but I have no ideas where to edit? Can anyone help? Thanks.

Labels (1)
Tags (1)
0 Karma
1 Solution

ragedsparrow
SplunkTrust
SplunkTrust

You will have to go into the role settings and make sure that the index you are wanting to search is within the default indexes for the role that you are under:

You can see/change this under Settings » Users and Authentication » Roles » < Your Role > » Default indexes

The menus are a little different between 7.x and 8.x.

In 8.x you will select your role and find the indexes tab. Then choose the index and make sure that "Default" is checked.
In 7.x you will scroll to the bottom of the page for your role and make sure that the index you are needing is selected for "Indexes searched by default"

View solution in original post

ragedsparrow
SplunkTrust
SplunkTrust

You will have to go into the role settings and make sure that the index you are wanting to search is within the default indexes for the role that you are under:

You can see/change this under Settings » Users and Authentication » Roles » < Your Role > » Default indexes

The menus are a little different between 7.x and 8.x.

In 8.x you will select your role and find the indexes tab. Then choose the index and make sure that "Default" is checked.
In 7.x you will scroll to the bottom of the page for your role and make sure that the index you are needing is selected for "Indexes searched by default"

View solution in original post

lucas4394
Path Finder

Thank you. Finally! 😄

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.