Splunk Enterprise

Problems executing scripts after an alert has been triggered in Splunk 8.2.0

kaurinko
Communicator

Hi,

I just realized a problem that had surfaced with the installation of Splunk v. 8.2.0. I have a number of alerts executing external scripts in ~splunk/bin/scripts and this system has worked fine fine for years. Yesterday I realized the scripts were being executed, but at the end of the chain the Perl-scripts tries to execute a system-command, which simply fails with return code 134. Naturally I could execute the scripts interactively as splunk user without trouble. Only executing them from splunkd would fail.

After hours of headbanging I had to work around the system commands, and write the commands to a queue and separately handle the queue with an external system. Now it works, but I find it disturbing, that all of a sudden something that has worked fine starts to fail without a clear reason. Time history associates the problems to the installation of Splunk v. 8.2.0. I won't bother filing a bug report, because it would be impossible for me to show beyond reasonable doubt that it is the Splunk 8.2.0 that actually is broken. This is just one of those issues of mixing Python, bash, Perl and se-linux to name a few well known candidates to blame. It is always someone else's fault.

Anyone else experiencing similar issues? It would be delightful to avoid fighting this problem again at some other point.

Br, Petri

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...