Splunk Enterprise

Encountering errors when loading analytics workspace after 8.1 upgrade

JHHenson
Engager

We have recently upgraded our non-prod Splunk Enterprise single instance environment, and have notice a couple errors when we load the analytics workspace. The errors says "Maximum call stack size exceeded." I am unsure which features of the Analytics Workspace this could be affecting, and I can't find any errors in Splunkd which could explain the cause of the errors.

Screenshot 2020-12-09 at 15.40.07.png

sbrice18
Path Finder

We are having a similar issue but with permissions.  Opened a support ticket initially and it looked like a role was missing but after adding the role the error is still persistent.  We also added the capabilities that were missing with that role but that didn't fix it either.

 

### Missing Windows Capabilities
[capability::edit_modinput_winhostmon]
[capability::edit_modinput_winnetmon]
[capability::edit_modinput_winprintmon]
[capability::edit_modinput_perfmon]
[capability::edit_modinput_admon]

 

[role_window-admin]
edit_modinput_winhostmon = enabled
edit_modinput_winnetmon = enabled
edit_modinput_winprintmon = enabled
edit_modinput_perfmon = enabled
edit_modinput_admon = enabled

 

sbrice18_1-1639060954552.png

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...