Splunk Enterprise Security

Splunk Query related

rupesh67nikam
New Member

I've written below query,

index=* sourcetype=* EventCode=* | rex field=_raw "((Process Command Line:\t)(?(.+)*))" |stats count by field.

Tried extracting "Process Command line" field. After extracting i can see that though it doesn't contain any value(not even spaces), Splunk is not taking it as NULL.Instead it is taking as if field has some command line.

Could you please help?

0 Karma

vikcee
Path Finder

Please Provide the Sample log, So that we can see if is there any issue with rex or something else.

Normally rex syntax is like below.
(?<Field_Name>Regular_Expression)

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @rupesh67nikam,
I cannot read you search, you should insert it in Sample Code.

Anyway, in your regex I see spaces in field name (but could be a visualization error) and it's better not use them.
Then in stats count BY field command, you should use a field name (not field), e.g. something like

| stats count by Process_Command_Line

or

| stats count by "Process Command Line"

Ciao.
Giuseppe

0 Karma

Sukisen1981
Champion

could you please provide samples of your raw event and what you want to extract out of that?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...